Szukaj w:
.

 Zobacz Temat

Strona Główna Forum | eXtreme-fusion 5.0 | Poradniki
1 2 »
#128601 03.08.2013 14:00:08 - eXtreme-Fusion 5.0.3 w Bitnami.com
Avatar Użytkownika
Ostrzeżeń: 1
Postów: 8
Post napisano: 03.08.2013 14:00:08
phpinfo: http://segoda.cha...hpinfo.php
platforma: extreme-fusion-5.0.3
system LAMP z bitnami.com (środowisko serwera+php+mysql+inne wymagane biblioteki w sandbox tworzone przez standardowe instalatory z bitnami.com) na ubuntu-12.04-desktop-x86_64.
Dodam, że jako nie ma gotowej instalki dla extf musiałem ją stworzyć samemu w oparciu o proponowany w serwisie bitnami.com ( http://wiki.bitna...pache+LAMP ) standardowy plik konfiguracyjny aplikacji korzystający z owego LAMP:
Alias /extf/ "/home/segoda/bitnami/apps/extf/htdocs/"
Alias /extf "/home/segoda/bitnami/apps/extf/htdocs"

<Directory "/home/segoda/bitnami/apps/extf/htdocs">
  Options +MultiViews
  AllowOverride None
  <IfVersion < 2.3 >
  Order allow,deny
  Allow from all
  </IfVersion>
  <IfVersion >= 2.3>
  Require all granted
  </IfVersion>
</Directory>


Jest jeszcze odwołanie do apache typu Include ze ścieżka do ewentualnego pliku htaccess.conf, ale go zamarkowałem # , gdyż nie mam pojęcia jak go stworzyć i po co skoro już jest w samym katalogu extf.
Oczywiście ścieżki wynikają z logiki instalacji samego LAMP, i.t.d.

Generalnie działa mi tylko pierwsza strona główna portalu extf ( http://segoda.cha...6222/extf/ ) - nie mogę przejść do żadnej innej zakładki, podstrony czy jak to zwał, oferowanej przez domyślną instalację, a więc np. gdy klikam "forum" (tak forum udało mi sie zainstalować, gdyż działa zarówno logowanie do ACP czy do serwisu jak i poruszanie sie po nim, ale np. wylogować się już nie mogę - ta sama strona błędu) pojawia mi się w przeglądarce następujący błąd:
404 Not Found (nazwa strony)

Not Found

The requested URL /extf/forum.html was not found on this server.


Wygląda, że extf wymaga jakiegoś szczególnego pliku .htaccess i/lub ustawień w PHP, czy sam już nie wiem czego - instalator LAMP bitnami jest bardzo uniwersalny i pozwala na instalację wielu CMS-ów, więc to chyba raczej nie braki w samym środowisku serwera (a może jednak czegoś mu brak - sam już nie wiem).
Na tej samej instalacji działają bez problemu inne instalacje, innych środowisk, np.: mybb (moja konfiguracja - też brak standardowego instalatora), phpbb3 (instalator z bitnami), wordpress (instalator z bitnami), i.t.d. - można to stwierdzić na strone wirtualnej domeny http://segoda.cha...p.net:6222

Proszę o jakąś konkretną pomoc (bez odsyłania do innych stron w sieci) jak sprawić by extf-5.0.3 działał w pełni sprawnie (prawdopodobnie problemy z konfiguracją apache + być może nieodpowiedni, domyślny plik .htacces oferowany przez extf przy domyślnej instalacji). W razie braku interesujących informacji, mogących przybliżyć istotę problemu będę odpowiadał w miarę potrzeby na dodatkowe pytania, służył konfigami, i.t.d.
Z góry dodam, że ze względu na określoną sytuację na moim kompie nie wchodzi w grę instalowanie standardowo apache w oparciu o to co oferuje ubuntu.
Z góry dziekuję za pomoc.
smiley
Wyślij Prywatną Wiadomość
#128603 03.08.2013 18:08:22 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 1435
Post napisano: 03.08.2013 18:08:22
Nie czyta pliku .htaccess, który jest dostępny w EF w katalogu głównym.
Być może nie masz włączonego mod_rewrite w Apache, o ile w w ogóle jest to Apache?

W obu przypadkach wystarczy, byś w klasie System (system/class) zamienił metodę rewriteAvailable() na:

// Zwraca info czy modRewrite aktywny
  public function rewriteAvailable()
  {
   return FALSE;
   if ($this->_rewrite_available !== NULL)
   {
     return $this->_rewrite_available;
   }

   return $this->_rewrite_available = $this->apacheModuleLoaded('mod_rewrite') || $this->_rewrite;
  }


Następnie wyczyść zawartość katalogu cache.
Wyślij Prywatną Wiadomość
#128604 03.08.2013 18:10:42 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 1
Postów: 8
Post napisano: 03.08.2013 18:10:42
Właśnie miałem jeszcze o tym napisać w głównym wątku ale zapomniałem - oczywiście mod_rewrite jest standardowo włączony dla tego ustrojstwa.
Co do faktu, że jest to apache to raczej tak wynika zarówno z typowych binarek, bibliotek oraz konfigów oraz wyraźnie to pokazuje link z pierwszej linijki 1 wątku.

Tworzyłem równiez sam niezbędny plik htaccess.conf w przeróżnych konfiguracjach ale bezowocnie. Nazwa i umiejscowienie w korzeniu owego pliku wynika oczywiście ze specyfiki działania owego LAMP - czyli konkretnie tu ~/bitnami/apps/htdocs/conf/htaccess.conf).

Faktycznie - dodanie prostego wpisu pomogło, czyli konkretnie w tym przypadku:
return FALSE;
z zacytowanego powyżej fragmentu w pliku <główny katalog exft>/system/class/System.php (czyli pełna ścieżka z systemu ubuntu: /home/segoda/bitnami/apps/extf/htdocs/extf/system/class/System.php).
W ramach wyczyszczenia cache po prostu zrestartowałem apache i mysql przy pomocy standardowego ustrojstwa z bitnami.
Tak czy inaczej dziękuję - już działa - japę cieszy...
:D
Wyślij Prywatną Wiadomość
#128605 03.08.2013 18:16:26 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 1435
Post napisano: 03.08.2013 18:16:26
Rozumiem że ten plik w ogóle masz w /home/segoda/bitnami/apps/extf/htdocs? Sprawdź, co masz na jego końcu.
Wyślij Prywatną Wiadomość
#128606 03.08.2013 18:29:13 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 1
Postów: 8
Post napisano: 03.08.2013 18:29:13
Mam, mam...to oczywiste (przynajmniej dla mnie - hehe) - odpowiedziałem szczegółowo w poprzednim komentarzu. smiley

1). Pytanie za 100 pkt - o jakiej treści spłodzić dodatkowy plik dla serwera apache (wspomniany htaccess.conf) abym nie musiał za każdym razem po instalacji edytować owego, w/w System.php (standardowe konfigi na włączenie mod_rewrite nie działają) ?

2). Oraz pytanie dodatkowe - dlaczego liczba miesięcy zarówno na np. http://extf.askme... (dla testu zainstalowałem - poglądowo) czy też u mnie w domu wyświetla się z błędem ?
Zwróć uwagę w phpinfo, że nawet wymusiłem na tym sandbox-LAMP (w domu) odpowiednie locale i strefę czasową (teoretycznie czego nie pobierze owo php z sandboxa powinno pobrać z systemu ubuntu - o ile to nie błąd w samym extf-5.0.3).

3). I może jeszcze jedno globalne (żeby nie tworzyć kolejnego tematu) - dlaczego w domyślnej instalacji i motywie po wylogowaniu z ACP nie przenosi na stronę główną ?
Wyślij Prywatną Wiadomość
#128608 03.08.2013 23:04:44 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 1907
Post napisano: 03.08.2013 23:04:44
W pliku konfiguracyjnym:
<Directory />
  Options FollowSymLinks
  AllowOverride All
</Directory>


I będzie działać Ci mod_rewrite wraz z przyjaznymi linkami.

Co do misięcy nie rozumiem za bardzo.
A przy wylogowaniu z którego panelu administracyjnego?

PS. Posiadam ten sam system co Ty, wszystko mi działa :)

Wyślij Prywatną Wiadomość
#128610 04.08.2013 01:57:00 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 1
Postów: 8
Post napisano: 04.08.2013 01:57:00
Add@... Czy tak będzie dobrze czy jednak wywalić +MultiViews ?
Alias /extf/ "/home/segoda/bitnami/apps/extf/htdocs/"
Alias /extf "/home/segoda/bitnami/apps/extf/htdocs"

<Directory "/home/segoda/bitnami/apps/extf/htdocs">
  Options +MultiViews FollowSymlink
  AllowOverride All
  <IfVersion < 2.3 >
  Order allow,deny
  Allow from all
  </IfVersion>
  <IfVersion >= 2.3>
  Require all granted
  </IfVersion>
</Directory>

#Include /home/segoda/bitnami/apps/extf/conf/htaccess.conf

To jest w zasadzie jeden plik konfiguracyjny extf.conf (dodatkowe wynikają albo z Includes albo z głównego httpd.conf).

Add@...Jak wejdziesz na podany w pierwszym poście i spojżysz na komenty w czatach widać wyraźnie, że źle koduje (w sensie wyświetla nazwę nie po polsku...tylko prawie po polsku) nazwę miesięcy (na końcu takie L jakieś czy cuś - sierpieL' - tak mniej więcej).

Add@...Z tego panelu, który jest chyba tylko jeden administracyjnym (chyba, że jest więcej paneli administracyjnych...to nie wiedziałem), np. jak kliknę na dole strony "Admin Control Panel" lub przy profilu "Administracja" przenosi mnie na zaplecze (jak pierwszy raz przez "Administracja" to na stronę logowania do owego zaplecza - jak kolejny, to w to miejsce z którego ostatnio przełączyłem się w owym zapleczu na widok srtrony głównej). Gdy się wyloguję będąc na danej podstronie zaplecza nie przenosi mnie na stronę główną tylko na stronę logowania do zaplecza (nie ma tam żadnych klików by przejść z niej na np. stronę główną - np. podobnie jak w MyBB).
Nie wiem jak jeszcze bardziej dokładnie opisać o co mi chodzi. :D

Ehh, chyba sam się teraz złapałem na błędzie, czyli ma być tak w całości ?
Alias /extf/ "/home/segoda/bitnami/apps/extf/htdocs/"
Alias /extf "/home/segoda/bitnami/apps/extf/htdocs"

<Directory "/home/segoda/bitnami/apps/extf/htdocs">
  Options +MultiViews
  AllowOverride None
<Directory />
 Options FollowSymLinks
 AllowOverride All
  <IfVersion < 2.3 >
  Order allow,deny
  Allow from all
  </IfVersion>
  <IfVersion >= 2.3>
  Require all granted
  </IfVersion>

</Directory>

#Include /home/segoda/bitnami/apps/extf/conf/htaccess.conf


...albo już sam nie wiem jak...
Tak czy inaczej ani tak ani jak sam wykumałem nie działa...httpd startuje z błędem albo przełącza na stronę błędu po kliknieciu na podstronę - w obu przypadkach działa tylko strona główna.
Jak daję bez + to śpiewa następująco sam apache:

AH00526: Syntax error on line 5 of /home/segoda/bitnami/apps/extf/conf/extf.conf:
Either all Options must start with + or -, or no Option may.

A wgłównym pliku konfiguracyjnym apache (httpd.conf) takiej opcji nie dam bo koliduje z innymi apsami webowymi.
W związku z tym zmieniłem na coś takiego sam extf.conf:
Alias /extf/ "/home/segoda/bitnami/apps/extf/htdocs/"
Alias /extf "/home/segoda/bitnami/apps/extf/htdocs"

<Directory "/home/segoda/bitnami/apps/extf/htdocs">
  Options +MultiViews
  AllowOverride None
  <IfVersion < 2.3 >
  Order allow,deny
  Allow from all
  </IfVersion>
  <IfVersion >= 2.3>
  Require all granted
  </IfVersion>
</Directory>
<Directory />
 Options FollowSymLinks
 AllowOverride All
</Directory>

#Include /home/segoda/bitnami/apps/extf/conf/htaccess.conf

Nie pluje już błędami sam apache ale i nadal nie przełącza na podstrony tylko na strony błędów.
Oczywiście we wszystkich przykładach usunąłem dyrektywę/komendę/fragment php, który dodałem wcześniej w /home/segoda/bitnami/apps/extf/htdocs/extf/system/class/System.php.
return FALSE;


Nie można tej dyrektywy zmergować z głównym korzeniem na github w tym danym pliku ? Koliduje jakoś znacząco z całą platformą lub innymi typami instalacji na różnych hostach ?
Poza tym dodanie
<Directory />
 Options FollowSymLinks
 AllowOverride All
</Directory>

do pliku httpd-apps.conf (nazewnictwo zgodne z obecną ideologią bitnami i konfiguracją danej aplikacji pod aktualną wersję LAMP Stack) zakłóca bezpieczeństwo całego apache i ustawia go jednak globalnie, czego właśnie chciałbym nie robić - inne appsy mają wtedy problemy - albo się mylę, to proszę mnie sprostować.
Wyślij Prywatną Wiadomość
#128611 04.08.2013 10:59:30 - RE: problemy prawdopodobnie z htaccess na domowej instalacji bitnami
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 1907
Post napisano: 04.08.2013 10:59:30
Mój alias wygląda następująco:
Listen 9000
<VirtualHost *:9000>
  ServerAdmin kontakt@rafik.eu
  ServerName http://rafik.eu
    ServerAlias rafik.eu.pl

  DocumentRoot /var/www/projekty
  <Directory />
   Options FollowSymLinks
   AllowOverride All
  </Directory>
  <Directory /var/www/projekty/>
   Options Indexes FollowSymLinks MultiViews
   AllowOverride All
   Order allow,deny
   allow from all
  </Directory>

  ErrorLog ${APACHE_LOG_DIR}/error.log

  # Possible values include: debug, info, notice, warn, error, crit,
  # alert, emerg.
  LogLevel warn

  CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>


Nie zmieniam nic w plikach eXtreme-Fusion i wszystko działa.

Co do braku linku w miejscu panelu logowania do panelu administracyjnego dodamy go w następnej wersji.

A miesiące już myślę, że będą poprawnie wyświetlane :)
https://github.co...2b74de5e0b
Wyślij Prywatną Wiadomość
1 2 »


Szybka Odpowiedź


Musisz się zalogować by móc zamieszczać posty w tym temacie.