Szukaj w:
.

 Zobacz Temat

Strona Główna Forum | eXtreme-fusion 5.0 | Poradniki
#126931 20.07.2012 00:24:32 - Linkowanie plików .js w szablonie
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 6
Post napisano: 20.07.2012 00:24:32
Witam Mam taki problem w pisaniu "szablonu" pod EF V
że nie da się podlinkować pliku .js pod efekt jquery-accordion...

A dokładniej wpisuje w pliku core/theme.php

 <link href="styles/slider_style.css" rel="stylesheet" type="text/css" /><br>
<br>
<script type="text/javascript" src="scripts/onload.js"></script><br>
<script type="text/javascript" src="scripts/onload_home.js"></script><br>
<script type="text/javascript" src="scripts/jquery.mousewheel.min.js"></script><br>
 <script type="text/javascript" src="scripts/jquery.lavalamp.min.js"></script><br>


i w otwartej stronie nic nie widać (oprócz grafik )
tak samo się dzieje jak próbuje linkować te pliki w page.tpl
... więc mam takie pytanie gdzie i jak w którym pliku należy zalinkować takie pliki .js ??

PS.dodam jeszcze że wszystkie grafiki są wyświetlane poprawnie co wskazuje że plik .css został dobrze podlinkowany.
Wyślij Prywatną Wiadomość
#126932 20.07.2012 08:51:05 - RE: Linkowanie plików .js w szablonie
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 1012
Post napisano: 20.07.2012 08:51:05
Jeśli w themie chcesz mieć inny nagłówek (sekcja header itp) to robisz sobie katalog:
./themes/twoj_theme/templates/pre/
I kopiujesz sobie wszystkie pliki z :
./templates/pre/
I edytujesz je dowolnie. Wtedy te pliki będą wczytywane zamiast standardowych.

A jeśli nie chcesz mieć swojego header, footer itp, to zmodyfikuj standardowy:
./templates/pre/header.tpl

Ale to zadziała tylko na Twojej stronie, lub po zmodyfikowaniu pliku który sam modyfikowałeś.
Wyślij Prywatną Wiadomość
#126933 20.07.2012 09:50:49 - RE: Linkowanie plików .js w szablonie
Avatar Użytkownika
Ostrzeżeń: 0
Postów: 6
Post napisano: 20.07.2012 09:50:49
szefie jak robi się skórki to ja wiem ;) to co napisałeś to sam rozkminiłem już parę dni temu ...

Mam taki problem że linkuje :
<link href="{$THEME_CSS}style.css" media="screen" rel="stylesheet" />
<link href="{$THEME_CSS}styl_news.css" media="screen" rel="stylesheet" />
<link href="{$THEME_CSS}styl_paneli.css" media="screen" rel="stylesheet" />

<script src="{$THEME_JS}jquery.min.js"></script>
<script src="{$THEME_JS}jquery.ace.js"></script>
<script src="{$THEME_JS}jquery.slides.js"></script>

I wszystkie pliki css działają poprawnie ale plik js jest olewany :) a dokładniej jest olewany plik ace który odpowiada za efekt accordion w newsie... (ale już w panelu menu ten plik działa ok tak samo jak w ostatnich postach na forum ... wszystko jest poprawnie zwiane ) dlatego mam wrażenie że od sekcji news musi być oddzielnie podlinkowany w jakimś innym pliku ...

Ps... ktoś wie gdzie to można podlinkować ???

ten plik nawet zwija poprawnie posty n S.B. ale ku... w news nie da rady nic zrobić ... i proszę mi powiedzieć jak to podlinkować pod newsy żeby tam to działało :)

Fatal error: Uncaught exception 'systemException' with message 'Nieprawidłowy typ danych. Oczekiwano wartości numerycznej, a otrzymano: ' in /home/inscure/domains/extreme-fusion.pl/public_html/system/class/edit.php:98 Stack trace: #0 /home/inscure/domains/extreme-fusion.pl/public_html/system/helpers/main.php(57): Edit->isNum(true, true) #1 /home/inscure/domains/extreme-fusion.pl/public_html/system/class/user.php(762): isNum(false) #2 /home/inscure/domains/extreme-fusion.pl/public_html/system/class/user.php(669): User->getByID(false, 'username') #3 /home/inscure/domains/extreme-fusion.pl/public_html/system/helpers/main.php(251): User->getUsername(false) #4 /home/inscure/domains/extreme-fusion.pl/public_html/forum/viewthread.php(436): HELP::profileLink('wolffmrau') #5 {main} thrown in /home/inscure/domains/extreme-fusion.pl/public_html/system/class/edit.php on line 98